HOME PRODUCTS FORUM RESOURCES KIT COMPARISON FREQUENTLY ASKED QUESTIONS  
GALLERY HISTORY VO THEORY SYSTEM MEDIA CONTACT  


Go Back   Forums > Vegetable Oil Forum > Technical discussion
Register User's Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 02-04-2011, 01:04 PM
ak94's Avatar
ak94 ak94 is offline
Member
 
Join Date: Jun 2008
Location: Alaska
Posts: 50
Default In tank heat exchanger leaking

About 2 years ago I purchased a frybrid kit for my 94 f-250 IDI. I installed the kit and it ran great........ except. Within 70 miles of driving I had VO in my coolant and coolant in my VO tank. I was about to move and had no time to work on it. I drained my coolant and shutoff the VO system. I have driven the last 2 years a several thousand miles with no problems. Now that I had time to devote to this project I have finally found where the leak is. I pressurized the coolant system and lots of air and coolant blew into my VO tank. Because of the shell on the heat exchanger I can not see the leak, or know how big the hole is. I can only conclude that it was ether a small imperfection in welding or it was damaged in shipment. But regardless, it was leaking from the day that I installed it. What should I do?
thanks for any help,
__________________
1994 Ford 7.3 IDI, factory Turbo, 4x4, Auto, Ex-cab Longbed 112,000mi
Reply With Quote
  #2  
Old 02-04-2011, 03:09 PM
cgoodwin's Avatar
cgoodwin cgoodwin is offline
Administrator
 
Join Date: Jan 2005
Posts: 13,394
Default

Send it to me and I will replace it.

Happy birthday.
__________________

Life is either a daring adventure or nothing. Security does not exist in nature, nor do the children of men as a whole experience it. Avoiding danger is no safer in the long run than exposure.
-Helen Keller

I am putting myself to the fullest possible use, which is all I think that any conscious entity can ever hope to do.
-HAL9000

Reply With Quote
  #3  
Old 02-04-2011, 03:19 PM
ak94's Avatar
ak94 ak94 is offline
Member
 
Join Date: Jun 2008
Location: Alaska
Posts: 50
Default

Thank you,
I appreciate the quality of your kits and the work you put into them.
I will send it off ASAP.

Thanks again
__________________
1994 Ford 7.3 IDI, factory Turbo, 4x4, Auto, Ex-cab Longbed 112,000mi
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 05:34 PM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.